Increased Latency on Analytics API

Incident Report for NeuroID

Postmortem

On October 17, 2025, from approximately 4:26 PM EST to 4:32 PM EST, Neuro-ID experienced increased response times for v5 and v6 Analytics API requests (api.neuro-id.com/v5/ and api.neuro-id.com/v6/). Additionally, during this incident, requests for scores from the v5 and v6 Analytics APIs may have encountered a higher rate of stale or 404 (Not Found) responses. No event data was lost during this time, and all session scoring was completed and remained accessible via the Analytics API.

The incident was caused by unintended requests against the API endpoint that had unexpected consequences to internal systems. These requests were stopped immediately and an investigation is happening to understand why the latency increase was observed.

v4.1 Endpoint remained unaffected.

Posted Oct 17, 2025 - 20:53 UTC

Resolved

On October 17, 2025, from approximately 4:26 PM EST to 4:32 PM EST, Neuro-ID experienced increased response times for v5 and v6 Analytics API requests (api.neuro-id.com/v5/ and api.neuro-id.com/v6/). Additionally, during this incident, requests for scores from the v5 and v6 Analytics APIs may have encountered a higher rate of stale or 404 (Not Found) responses. No event data was lost during this time, and all session scoring was completed and remained accessible via the Analytics API.

The incident was caused by unintended requests against the API endpoint that had unexpected consequences to internal systems. These requests were stopped immediately and an investigation is happening to understand why the latency increase was observed.

v4.1 Endpoint remained unaffected.
Posted Oct 17, 2025 - 20:53 UTC
This incident affected: Analytics API.