Increased Analytics API request timeouts

Incident Report for NeuroID

Postmortem

On January 21, 2026, Neuro-ID experienced intermittent outages affecting the Analytics API (api.neuro-id.com) across all endpoints. Starting at approximately 19:03 UTC, there were three separate 4-minute periods of unavailability: 19:03–19:07 UTC, 19:11-19:15 UTC, and 19:26-19:31 UTC. There was an additional period later Jan 22, 2026 00:56-01:00 UTC. During these intervals, API responses may have timed out or returned errors.

The outages coincided with increased network latency in several internal systems, which most significantly impacted the Analytics API’s ability to respond to requests promptly. Services recovered automatically, and additional resources have since been provisioned to mitigate the impact of similar network instability in the future.

Posted Jan 22, 2026 - 19:09 UTC

Resolved

This incident has been resolved. A detailed postmortem will be added here once completed.
Posted Jan 21, 2026 - 21:12 UTC

Monitoring

We are currently monitoring a system update applied to address this issue.
Posted Jan 21, 2026 - 20:10 UTC

Investigating

We are currently investigating an increase in Analytics API request timeouts.
Posted Jan 21, 2026 - 19:24 UTC
This incident affected: Analytics API.