Increased Analytics API request timeouts

Incident Report for NeuroID

Postmortem

On April 23, 2026, Neuro-ID experienced intermittent outages affecting the Analytics API (api.neuro-id.com) across all endpoints. The issue starting at approximately 16:30 Eastern and lasted about 2 minutes. Some API requests during this time may have timed out.

The outages coincided with a deployment that unexpectedly changed network settings. During the moment the network settings were changed, API requests were lost. The change happened very quickly, and once fully provisioned, API calls functioned as expected.

During this incident:

  • Event collection was not impacted.
  • Portal dashboards and Crowd Alert notifications were not impacted.
  • Neuro-ID’s portal remained available and fully functional throughout the incident.

For a detailed Root Cause Analysis (RCA) or additional assistance, please contact your Customer Success Manager.

Posted Apr 23, 2026 - 21:26 UTC

Resolved

On April 23, 2026 from 4:30 PM Eastern Time to 4:32 PM Eastern time we observed an increase in Analytics API request timeouts. During this period requests to the Analytics API may have timed out.
Posted Apr 23, 2026 - 21:21 UTC
This incident affected: Analytics API.